Sales reporting basics

Hello everybody,
I need to find out how many of the different items I sold last year. As my stock administrations was extremely messy, due to all the Tryton introduction troubles, I should sum it up over all sales, and not calculate it on base of stock moves.

I found the sales > report > sales menu item, tried “per item” and per category, but always end up with an empty window. (I choose a period of time and a warehouse as well). What could I do wrong - or should I try another approach?

Cheers,
Wolf

This is probably because you do not have a currency rate for your company currency.

I have the currency module installed and activiated, but only use one currency in my little company. I could not find a “currency” menu entry, neither any other “currency” item. Where would I have to look for it?
Thanks a lot in advance,
Wolf

By default currency should be a main menu item.
Check that your user has permission in Administration/Users/Access Permissions.
Your user should have access to Group Currency Administration in order to be able to see the Currency menu item.

I’m admin, so I think I should have access to everything…? - This is how permissions in currency administration look like:

Your screenshot shows that the group Currency Administrator has access to the Currency Model, this is default.

However your User also needs to be in the Currency Administrator group.

PS: Or check the members tab in the group which you are showing in your screenshot.
Your current user should be in there.

AFAIK, the user “admin” is in the currency administration group:

Bildschirmfoto von 2021-07-19 11-33-10

Does it need further permissions at “access field” (right side):

Cheers,
Wolf

In such a situation I would create a new database in a separate venv and then compare the settings with the production database. menu,

AFAIK permissions are checked if there is an entry.
For this reason my understanding is that if there is nothing in access field, that should mean no checking, thus access granted.

Two more things i guess you can check: In the last tab, menu, there should be the currency in the list.

Maybe you could also check the menu from Administration/User Interface/Menu, and also with which menu your user is associated.

We’re getting closer, Creating a unspoiled VENV is a really good idea - and my brand new installation script creates one in less than 10’ (:

Actually, guess I found the culprit - in
Administration > Users > Groups > Currency Administration ==> Tab “Access permission”
I cannot find “currency” which is in the virginal version:

Bildschirmfoto von 2021-07-19 13-57-59

Unluckily, “currency” is not in the list under the blue +.
The “currency” module is acitvated…

I found that I didn’t have the “currency” entries in
Administration > user interface > menu
I created a new one following my “virgin” install - é voilá - the currency Menu is there, and I filled in “1” as my exchange rate, as EUR is my only currency.

But still: When I try to get a report as described in #1, nothing happens… ):
What could be wrong?

The rate must be set to a date before the first sale date.

It’s working now. Guess my basic mistake was to think “I do not need foreign currencies” and eliminated the menu entry for that reason.
Pity that our very experts repeatedly have to waste their precious time to deal with such dumb mistakes. They could could be avoided if there would be an easily accessible check list what to to when beginning in Tryton. ):
Anyway - thank you very much for your support.