SAO Client connecting, GTK not


(Hendrik Brandes) #1

Hello,

I have installed the trytond 5.0 via docker and runs successfully. But: I can only access to tryton via the SAO-client and http. If I want to connect via the GTK-client, the client returns “Cannot connect to server”.

The server config file contains a [web]-section with the listen parameter. What I am wondering about, is the fact, that the SAO can connect and the gtk-client cannot connect - even it is the save address and port.

In the uwsgi-log there is not entry about the GTK login attemt…

Thank you for helping and best regards,
Hendrik


(resteve) #2

Yestarday I tried to connect to demo.tryton.org:

  • GTK -> Cannot connect to server. Ko.
  • SAO -> Ok.

(Cédric Krier) #3

This is a known issue that has been fixed. It will be on the next bugfix release.


(Hendrik Brandes) #4

Thank you for the fast answer. The patch works very well!


#5

I seem to have hit this issue.

I’ve tried seeing if I could make the changes this file in the docker -> /trytond/protocols/jsonrpc.py but it doesn’t appear to be the same file…

What is the best way for me to add this change to the official docker, so I can connect again with the gtk app pls?

Thanks in advance

Edit: Oops, missed the lack of a ‘d’, so this appears to be in the client code … going to look

Edit2: Okay so downloaded latest source and built, but it gives me another error -> ERROR:tryton.rpc:[Errno 0] Error Not sure what I am doing wrong.