URL with GTK client

Tried to install the GTK client and log into my (docker) server. Is the URL the same as with the web client - localhost:8000 ?

When I try, I get these error messages at the terminal:

ERROR:tryton.rpc:<Fault ‘410’: ‘Gone’
ERROR:tryton.rpc:[Errno 0] Error

What’s wrong?

Cheers,
Wolf

The desktop client is not configured by an URL but using the hostname:port + the database name.

This is not a status that the Tryton server returns so it must be some proxy that does not properly transfer the request to the Tryton server.

Understood. But how can I find out the credentials?

The passwords are the same as those when accessing from the web client.

Sorry, I may have asked in the wrong way. To my simple mind:
hostname = localhost
port = 8000

But that does not work. So which hostname and port is required? - How do I find out what I have to type into the “host” box?

The one you have setup/configured the server to listen.

Yes, even your username and password are the same as with the web client. When you start the GTK client for the first time, it will default go to the demo-server of tryton.org. You have to change some fields. Click on Host / Database information and change the Host to localhost:8000, the database to the database you want to connect and username to the username you want to login with.

Sorry, I’m still a little confused.

When I try the demo server, I get a “Cannot connect” message.
Terminal says this:

ERROR:tryton.rpc:<Fault ‘410’: ‘Gone’>

What could be the cause of not connecting? - I’m on a very vanilla ubuntu 18.04.

It seems like something is blocking the port 8000.
Could you try connecting in the browser to https://demo5.4.tryton.org:8000/#demo5.4/

Got the same issue here with the demo-server demo5.4.tryton.org

  • connecting with the browser works OK
  • connecting with the GTK client does not work

Starting the client with tryton -v I got:

INFO:tryton.rpc:common.server.version(None, None)
ERROR:tryton.rpc:[Errno -2] Name or service not known

Connecting to my own instances there are no problems.

Yes, I can connect to that page, but cannot login with database names “tryton5.4” oder “tryton” and user “demo” or “demo_de”. "

Bad gateway" error…

This is because the database name is demo5.4

Maybe you still have a known_hosts with demo5.4.tryton.org without the SSL fingerprint. So you can just remove that line.

That did the trick. Look in ~/.config/tryton/5.4/known_hosts and remove the entry for demo5.4.

@herrdeh you should be able to connect to the demo-server with:

Click on connect and enter admin as password.

Back on topic, if the above settings work, do you have your Trytond-server running on localhost?
Change the different fields:

  • Host -> localhost:8000
  • Database -> the name of your test database
  • username -> admin

I think you can see a pattern here. If you cannot connect and you have to wait some time before you get an answer, it can be a firewall issue. However, you also shouldn’t be able to connect with the browser.

There is something weird going on here. The link isn’t working, the database field is not filled in and you get an ‘Bad Gateway’ error with the right database name and username. However when you remove the port 8000 (including the colon) it’s working.

Works only with omitting the “:8000”.

I fixed it. The configuration of ngnix was using $host to set the X-Forwarded-Host header but it does not contain the port, so the CORS validation was applied. Now it set the header using $http_host which include the port.

This throws a http 400 error now.

At the GTK client, when trying to connect to demo5.4, it says “server version incompatible”. Which makes sense to me, my client it the vanilla ubuntu one - v. 4.8.22.

Can that be the problem with my local instance as well?

You must have the first two digits of the version the same. So when you have a Tryton-server version 5.4.3, you must have a client version of at least 5.4.0

So get the right version from https://downloads.tryton.org/ unpack it and run it.

Because it must be https like https://demo5.4.tryton.org:8000/

Fine. How do I find which tryton server version I’m running? -