Instalacion Tryton Argentina

Estimados que tal. Buenas noches.

Quisiera consultarles cual es la ultima versión recomendable de Tryton para instalar con la localización argentina?

Saludos cordiales
Pablo Navarro

Always the latest version should be preferred.

Cómo dice @Ced, siempre es mejor la última, pero no sé si está 100% operativa para la localización Argentina. Nosotros usamos la 5.0 y funciona perfecto!
Saludos!

If there are some requirements missing in standard modules, they should be proposed for inclusion.
Being stuck on 5.0 (which is two years old) for new installation is a bad.

Normally the problem is due to not inclusion on standard modules as modules out of standard are migrated “when possible” so most of the time they are based on old series.

I agree that modules should be proposed for inclusion. We’ve discussed several time with some argentinan comunity members (see Localizacion ES_AR for example) but we are still facing the same problem. There is also Issue 8434: Argentina chart of account - Tryton issue tracker which misses some more feedback about Argentinian usage to have it clear. It will be great if somebody can continue it.

If you think we can do something to help this localization projects become a standard project please let us know.

1 Like

Perfecto, mas o menos se va entendiendo. Entonces:

  1. Donde consigo un script para instalar mediante PIP la versión 5 de Tryton sobre Ubuntu? O por lomenos un instructivo para instalarlo con todos los requerimientos necesarios porque la última vez que lo hice fue con la versión 3.4.

  2. Por que existe tanta incompatibilidad entre versiones y sus módulos? Es posible lograr aunque sea, compatibilidad entre las versiones 4 o compatibilidad entre todas las versiones 5?

Saludos
Pablo Navarro

En la imagen de docker tienes una muestra de como instalar todos los modulos de una version.
Solo tienes que modificar la variable de entorno series con las que quieras instalar.

Algunas mejoras requieren cambios de API que provocan las incompagobilidades. Para seguir mejorando Tryton se debe romper la compatibilidad entre versiones. De todos modos, si solo utilizas modulos estandard, las migraciones entre versiones son muy agiles!

No, si quieres estabilidad lo mejor es que los modulos de localizacion formen parte de los modulos estandar ya que una vez passado el proceso de inclusion los modulos estaran disponibles para todas las versiones

Sería genial que podamos agregar la localización Argentina al core. Me ofrezco para dedicarle tiempo y cabeza mas no código porque no tengo esas habilidades.
Saludos!

Me imagino que cuando se refieren a agregar la localizacion argentina al core se refieren a agregarla al paquete estandar de instalación de Tryton? Para que ya venga incluída de fábrica?

Saludos!

Si, a eso nos referimos. Eso es lo mejor que pueden hacer para la comunidad de usuarios argentinos y también para Tryton en general!

Si te fijas en el issue eso es justo lo que necessitamos ahora mismo. Habria que abrir un hilo en este discuss dónde se explique como se reportan los impuestos en argentina. Con esto podriamos hacer una propuesta de como implementar esto en un módulo generico de argentina.

Una vez tengamos claro el camino a seguir seguro que encontramos la forma de hacer que eso forme parte del core de Tryton.

4 posts were split to a new topic: About the current LTS model

Ok. Finalmente instalé Tryton 5.6 sobre Ubuntu 20.04 dentro de una máquina virtual (VirtualBox) siguiendo las instrucciones del hilo:

El sistema se instaló junto con el módulo Trytond_sale. La pregunta es:

Como instalo la localización Argentina y todos sus módulos?

Saludos
Pablo

Probablemente tienes que

pip3 install trytond_account_ar

Y asi por cada modulo que necesites, Probablemente tengas tambien que actualizar la base de datos:

trytond-admin -v -c trytond.conf -d BASEDATOS -u account_ar

Gracias Fredy. Voy a intentar con eso.

Saludos!

Buenas noches, Pablo el Tryton en su versión oficial no tiene integrado el plan de cuenta para Argentina, lo mas cercano podría ser https://github.com/gcoop-libre/trytond-account_coop_ar, que dice tenerlo para el sector cooperativo pero podría servir, el se encuentra para la versión de Tryton 5.0.1, como lo indica https://github.com/gcoop-libre/trytond-account_coop_ar/blob/master/tryton.cfg. También podrías contactarte con https://www.gcoop.coop/ si tienen alguno publicado en otro lugar para el sector comercial.

Para la instalación de módulos adicionales podrías listar los módulos disponibles en su última versión con:

pip search trytond

Y tomar de referencia de la lista de módulos oficiales del respositorio http://hg.tryton.org/modules.

Nota adicional:

Buscando un poco más encontré https://github.com/tryton-ar/account_ar, este se encuentra más actualizado.

Muy buena información. Las versiones 5 son compatibles entre si?

Saludos!

La versión 5 es una versión diferente a la 5.2 por ejemplo, pero en ocasiones pueden funcionar módulos que son de versiones anteriores, pero no es muy recomendable hacer estas combinaciones. En el caso de los planes de cuentas hay varios cambios entre los módulos de la 5 no operan en las posteriores (5.2,5.4,5.6). En conclusión si fueras a probar ese plan de cuentas que está para la 5, deberías instalar el trytond así:

pip install trytond==5.0
pip install trytond-account==5.0

y de esa forma para todos los módulos, para saber más información de las versiones disponibles de los módulos puedes usar:

pip install trytond-account==?

Las compatibles son las que empiezan con 5.0

Yo también estoy utilizando la verrsión 5.0 y nos funciona bien, vengo actualizando de la 3.8 si no recuerdo mal. Podría colaborar con la parte de código (estuve estudiando la generación de módulos) para que se incorpore en el core la localización Argentina, la parte contable no la tengo tan clara.

Los módulos que utilizo son:
party_ar
account_vouche_ar
account_check_ar
account_retention_ar
bank_ar
account_ar
account_bank_ar
account_invoice_ar