Where are the modules?

Hello Guys,

I have just installed tryton. Got great support from this forum.

But I need your help still to know where to download modules like banking, payment, sales, production, project, timesheet, etc

I am on Opensuse 15.1, gnuhealth 3.6.2, tryton 5.0.23, python3, sao

Hope you could help point a finger to where I could download the right ones from.

Thank you.

You should install the modules follow the same way as you installed trytond and respecting the same series. Most of the available ways are listed on Tryton - Get Tryton

Ok, thanks. So I downloaded trytond_company_work_time-5.0.2.tar and trytond_company_work_time-5.0.2.tar.gz.asc.
I then installed it according to the install file in it.
Unpacked the trytond_company_work_time, enter the directory where the archive was unpacked, and run:
python setup.py install (I had to use “python3 setup.py install” because installed python2.7 on the server was getting in the way)

After python installation which seemed to have went well the new module is listed in /usr/lib/python3.6/site-packages but not in /usr/lib/python3.6/site-packages/trytond/modules and it is nowhere to be found in tryton frontend Admin modules (installed modules remain 61 in total).

What am I doing wrong please?

Will appreciate your help,
Thanks.

Did you run the trytond-admin with the --update-modules-list option?

Nope. Not sure I’ve seen that before. I reckon that command should have been included in the install file. Will run it now. Is this the full command “/usr/bin/trytond-admin --update-modules-list” ?
Thanks Ced

Ok Ced, I’ve figured out how and where to run the command from.
As root, I did “su tryton -s /bin/bash” then “/usr/bin/trytond-admin --update-modules-list” So tryton complained: ImportError: No module named parse.
But tryton was using python2.7 instead of python3.6 (which is also installed)

So the question is how can I make tryton-admin use python3.6 to execute this command instead of python2.7 ?
I’ve found how to make tryton-admin use python3.6.
By adding “#!/usr/bin/python3” to the top of usr/bin/tryton-admin

Now usr/bin/tryton-admin is using python3 to execute “/usr/bin/trytond-admin --update-modules-list” but with the following error:
pkg_resources.ResolutionError: Script ‘script/tryton-admin’ not found in metadata at ‘/usr/lib/python3.6/site-packages/trytond-5.0.23-py3.6.egg-info’

How should I deal with this?

Thank you

In case you have installation from packages, just add the tryton repository and add additional modules(Packages) from YaST or zypper:

zypper ar -f https://download.opensuse.org/repositories/Application:/ERP:/Tryton:/5.0/openSUSE_Leap_15.1 tryton5

zypper in trytond_company_work_time 

(as example)

The installation of Tryton/GNU Health on openSUSE is pretty straight forward, which allows us for automated testing, see for example https://openqa.opensuse.org/tests/1304232

Thanks a lot.
Was able to add the repo and install company_work_time in yast. But the new module did not appear in Tryton Administration modules.
So I logged out of tryton admin and restarted service on server with “systemctl restart gnuhealth” and boom! tryton web page was gone! No indication of what happened in the log. Then I checked with “systemctl status gnuhealth” and got this error:
systemctl[1]: gnuhealth.service: Main process exited, code=exited, status=1/FAILURE
systemctl[1]: gnuhealth.service: Unit entered failed state.
systemctl[1]: gnuhealth.service: Failed with result ‘exit-code’

Googled to find a lead but couldn’t get anywhere.

Any idea what to do?

Appreciate your help, thanks.

Difficult to state from the distance.
First of all, installation of a module does not kill the server process on a clean installation (which I doubt you have - see other thread)
Did you run trytond-admin afterwards?
You may want to run the systemd-command manually to see what happens:
/usr/bin/trytond --config /etc/tryton/trytond.conf --pidfile=/var/lib/tryton/trytond.pid --logconf=/etc/tryton/trytond_log.conf

Tried both commands like you suggested and they both came up with the same error posted above earlier:
pkg_resources.ResolutionError: Script ‘script/tryton-admin’ not found in metadata at ‘/usr/lib/python3.6/site-packages/trytond-5.0.23-py3.6.egg-info’

I was shocked to see it crashed just like that too. May be there are remnants of old installs from earlier on but I’ve been trying to cleanup as I go to avoid situation like old buggers messing up the show. You guys know/understand the system way more than I do and I appreciate your support effort.

Looks like I have no choice but to start it all over again unless I wanna keep banging my head against the wall. Thank you coogor.