Sale_pos installation on Tryton version 5

Hi guys!,
Have somebody being successful installing zikzakmedia sale_pos module on Tryton version 5?..

I’ve tried unsuccessfully with both version 5.0 and 5.4, in every case I get an AssertionError, I’ve concluded that this happens as a result of some undeclared dependencies or the most simple fact that the published versions are not compatible with Tryton version 5 so far… here the stack trace that I end up with:

Traceback (most recent call last):
  File "/usr/local/trytond/lib/python3.6/site-packages/trytond/protocols/dispatcher.py", line 186, in _dispatch
    result = rpc.result(meth(*c_args, **c_kwargs))
  File "/usr/local/trytond/lib/python3.6/site-packages/trytond/wizard/wizard.py", line 286, in execute
    return wizard._execute(state_name)
  File "/usr/local/trytond/lib/python3.6/site-packages/trytond/wizard/wizard.py", line 317, in _execute
    result = self._execute(transition())
  File "/usr/local/trytond/lib/python3.6/site-packages/trytond/ir/module.py", line 582, in transition_upgrade
    pool.init(update=update, lang=lang)
  File "/usr/local/trytond/lib/python3.6/site-packages/trytond/pool.py", line 162, in init
    lang=lang, activatedeps=activatedeps)
  File "/usr/local/trytond/lib/python3.6/site-packages/trytond/modules/__init__.py", line 428, in load_modules
    _load_modules(update)
  File "/usr/local/trytond/lib/python3.6/site-packages/trytond/modules/__init__.py", line 393, in _load_modules
    load_module_graph(graph, pool, update, lang)
  File "/usr/local/trytond/lib/python3.6/site-packages/trytond/modules/__init__.py", line 202, in load_module_graph
    classes = pool.fill(module, modules)
  File "/usr/local/trytond/lib/python3.6/site-packages/trytond/pool.py", line 224, in fill
    assert issubclass(cls, PoolBase), cls
AssertionError: <class 'trytond.modules.sale_pos.sale.SalePaymentForm'>

IIRC this module requires a custom sale_payment module, not the one which is available on tryton.org

You should report this issue to the author of the module.

Thank you Sergi!,
I followed your advice and was able to install it without any problem… (I used the sale_payment module found in the Tryton Spain bitbucket repo if that helps other in my situation)

In the other hand, I thought that the “sale screen” was part of the module… it seems that it’s not the case and I’m going to need a client… what I’ve seen so far is the Presik qt app, are you aware of other options? (I’d prefer one with web interface),

Thank you again!,

IIRC this is the cas, there is a Sale POS View on the module that it is designaed specially for a point of sale (but without offline capabilities and so on).

You can check Issue 8737: Point of Sale - Tryton issue tracker that I had not yet time to finish.

1 Like

Hi Cedric,
I saw the thread and the current status of the project… It would be fantastic to have this project finalized!,
By the way… I’ll be happy to contribute with coding once the design be ready!,

You’re right!.. probably I’ve to enable some permission for it to appear (working on it!.. ),
BR,

Nevermind … actually it was already there… it was an expectations issue (when I saw the screen in list mode I thought it was a kind of report, but opening a new record it’s clear that this is the sales screen that I was looking for),

Thank you so much!,

The design is mainly fixed. You can see the few TODO left in the code.

I tried to download the repo but I got lost in the process :frowning: … I assume that the process should be the one shown here [Tryton - How to Develop] (Tryton - How to Develop) … however it seems like the repo isn’t alive:

    fflores@tlitpp-mac01:~/python_prjs$ hg clone https://hg.tryton.org/tryton-env
    abort: error: nodename nor servname provided, or not known

The other tool that I saw is the code review with the option to download the patch set… but I don’t think that this is the process, is it?

This is strange. Check that you have a recent mercurial version.

Indeed the repository for sale_point does not exist yet. So you have to download the patch and applied on a tryton-env clone. But I think I have to update the patch first to be sure it applies on recent version.

It’s working now… probably a temporary network problem,
Let me know when patch is up to date,

It is already updated to tip.