How to not automatically process records?

If I’m not wrong, when the worker is not activated in the tryrond.conf file, for example, a sale will be processed automatically when it gets confirmed. The same will happen when you have the worker activated in the trytond.conf but, you leave the sale_process_after field empty in the sale configuration.
I know that there is the possibility to just set the sale_process_after field to a big value, but it will create a register to ir_queue table each time anyway, so is there any way to just let the user process records manually?

  • Tryton version : 5.2

No the processing state is just an internal state, once a sale is confirmed there is no reason to no process it.

Indeed we did that sometimes. It was a little bit tricky as I set a context flag on the confirm button and do not create queue recors when this flag is set.

Why do you need to manually process the records?

Thank you. We will review if there is a real need in our scenario to manually process the sale.

Normally there is no real need, just an user that is used to the previous behaviour and wants to reduce the number of changes :wink: