Tryton 5.0 not starting on Ubuntu 18.04

Hi everyone,

I am having trouble getting 5.0 client to start on ubuntu 18.04.

When I run tryton, I get the error
Gtk-Message: 20:35:57.950: Failed to load module “topmenu-gtk-module”



Ubuntu used to put the menu in the top bar ala MacOS. Tryton 5.0 switched to GTK3, you probably need the module that put the menu bar on top for GTK3 if you don’t have it already.

Something like:

(but it depends on your distribution name, etc).

It looks like this is just a warning. Your issue is probably somewhere else. Could you put the full console output when launching the client?

Hi Cedric,

Of course. Thanks. Here it is:

paul@Ladon:~$ tryton
Gtk-Message: 20:35:57.950: Failed to load module "topmenu-gtk-module"
Traceback (most recent call last):
** File “/usr/local/bin/tryton”, line 4, in **
** import(‘pkg_resources’).run_script(‘tryton==5.0.5’, ‘tryton’)**
** File “/usr/local/lib/python2.7/dist-packages/pkg_resources/”, line 738, in run_script**
** self.require(requires)[0].run_script(script_name, ns)**
** File “/usr/local/lib/python2.7/dist-packages/pkg_resources/”, line 1499, in run_script**
** exec(code, namespace, namespace)**
** File “/usr/local/lib/python2.7/dist-packages/tryton-5.0.5-py2.7.egg/EGG-INFO/scripts/tryton”, line 48, in **
** from tryton.client import main**
** File “/usr/local/lib/python2.7/dist-packages/tryton-5.0.5-py2.7.egg/tryton/”, line 7, in **
** from urllib.parse import urlparse**
ImportError: No module named parse

Tryton 5.0 requires Python >= 3.4.

Yes. I have python 3.6.5. I am sorry, I just don’t know so I ask here. I have both python 2.7 and 3.6.5. How do I force 3.6.5?

I tried alias etc. I did the install as described in the doc/installation.rst

What do I change?

You installed it using Python2.7 because it is located in …lib/python2.7. You must run the with the python 3. Usually it is python3 install.

Ahh so. Silly me. Thank you so much for the help.

Yes you are correct of course. A message saying thank you is not a solution :smile:

In my case I also needed to do:
sudo apt-get install python3-pip
and then
python3 install

doc/installation.rst needs a small change.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.