Reset Password don't work

After adding a new user on tryton localhost , I was about clicking on the button “reset password”

The error was:

 Traceback (most recent call last):
      File "/trytond/", line 104, in dispatch_request
        return endpoint(request, **request.view_args)
      File "/trytond/protocols/", line 47, in rpc
        return methods.get(request.rpc_method, _dispatch)(
      File "/trytond/", line 72, in auth_required
        return wrapped(*args, **kwargs)
      File "/trytond/protocols/", line 131, in wrapper
        return func(request, pool, *args, **kwargs)
      File "/trytond/protocols/", line 209, in _dispatch
      File "/trytond/", line 221, in commit
      File "/trytond/", line 101, in tpc_vote
        self._server = get_smtp_server(self.uri)
      File "/trytond/", line 59, in get_smtp_server
        server = connector(uri.hostname, uri.port, **extra)
      File "/", line 253, in __init__
        (code, msg) = self.connect(host, port)
      File "/", line 339, in connect
        self.sock = self._get_socket(host, port, self.timeout)
      File "/", line 308, in _get_socket
        return socket.create_connection((host, port), timeout,
      File "/", line 808, in create_connection
        raise err
      File "/", line 796, in create_connection
    ConnectionRefusedError: [Errno 111] Connection refused

You need to set an smtp server to send emails from server. It seems your email server settings are not properly configured because the connection is refused.

if you mean about the configuration of the email server settings that must be added on trytond.conf , yeah i already added it , but i do no what’s wrong on my configuration exactly !
this how my trytond.conf how it looks like:

uri = postgresql://admin:xxx@localhost:5432/
path = /var/lib/tryton
language = en
auto_reload = True
root = /tmp/sao
hostname = ubuntu
listen =
authentications = password
max_age = 2592000
timeout = 36000
auto_reload = True
max_attempt = 5
max_attempt_ip_network = 300
ip_network_4 = 32
ip_network_6 = 56
length = 10
entropy = 0.75
reset_timeout = 86400
uri = smtp://localhost:25
from: "Company Inc"
store_prefix = None
long_polling_timeout = 300
cache_timeout = 300
select_timeout = 5
queue = True
class = trytond.bus.LongPollingBus

Hi Caroline,

For this part of the configuration to work you need to be running an SMTP server (on the same computer as you are running trytond) that accepts connections on port 25.

You would also normally set the from: address to an email address that you own.

Hi Dave ,
So what i understand from you that i should install and configure the SMTP server on port 25 on my localhost !

With your current setup you should install an SMTP server on the same machine you are running Tryton

If you already have an SMTP server running somewhere or you have an external mail provider you should modify your configuration to include the details of such server

Hi thank you helped me much , i figured out from the problem.

but i have some questions about the option reset password for the user

From the email sent :

The password for your account, **[](**, has been reset.
You must set a new one from the user's preferences.
You can connect with this temporary password **aXDKLjg39** to

Am still new on tryton and i want to know where i should type this link(tryton://ubuntu/database_name) and enter with the temporary password because what i know on the Tryton interface i could enter just with one login so what’s the benefits of this option "adding users and reset passwords " and where i can use it

1 Like

You must pass it as parameter of tryton. On some OS after installation of the client, the scheme tryton:// is registered to be opened with the client.
Otherwise you have to fill the hostname, database and user name in the “Host / Database information” of the login.

By the way you must use a very old Tryton version if you do not have also the URL in the email which link directly to the web client.

Hello ;
when i try to enter to this link from my browser , told me

Unable to connect
Firefox can’t establish a connection to the server 

also i tried to enter from the desktop client , i filled out those information on the desktop client :

Host : ubuntu(name of my localhost)
Database field (not exit to fill it out)

also on trytond.conf ,i added this line on(for all interfaces)
listen = [::]:8000

but it doesn’t works with me because on the desktop client on Profil i can’t select the Profil (hidden with gris color)that i added it now

Ps : the same thing happen on tryton 5.0 and 5.2 (i have two virtual environment )
if the problem is from the version , what’s the old version that you advice me to work with

You can expand the “Host / Database information” to directly fill the parameter (a profile is not strictly needed).

No but I would not advise to use an old (unmaintained version). So 5.2 is no more maintained. 5.0 is an LTS which starts to be old but still maintained.
Usually for new installation it is better to always use the latest version published. As today is 5.8 (and pretty soon 6.0).