On 7.2, property product_name was introduced:
@cached_property
def product_name(self):
name = super().product_name
if self.product_customer:
name = self.product_customer.rec_name
return name
I wonder if its not better to improve the naming with renaming the property to product_rec_name
, so we can create similar properties if I need the rec_name “split” like product_name
or product_code
because depending on the report I need a column with the code and other with the name.