Nginx errors over ssl for Tryton

I was setting up ssl on nginx for tryton. But nginx throws “Application error” “Not found” error when tried to login to tryton on port 9080 in the browser (just before the password page). And nginx has the following error in the /var/log/nginx/error.log

Tryton is still accessible on port 8000.

Other than I need to be on nginx support site, could someone please advise on where I got it wrong and how to fix it.


I see nothing really wrong here.
The web client tries to fetch the custom js and css files in case you want to customize. If you do not want to see those not found errors, you can still create empty files.
For the en_GB.json and en.json, it is because the language of the use is English so the web client tries to fetch the translations. But we do not provide translations for English because the terms are already in English. So you can just ignore those not found errors.

Thanks for your response.
I had created empty files for all the files it was missing. It then complained about missing index file in /opt/sao/trytondb/ which doesn’t exit. see log error below.

Apart from that tryton is still not accessible on with this error:

OK but there is obviously something wrong, tryton is still not accessible (not loading) on ssl port 9080. In nginx log there is “…/opt/sao/trytondb/index.html” is not found.

Tryton is configured to port 8000 and Nginx is configured to port 9080. Is this configured right?

Could someone please give some direction or point me to a documentation to give me an idea how to sort this out as I could not find anything anywhere about this Tryton ssl via Nginx from?

  • On what OS are you?
  • Have NginX access rights to the directory? Check the user / group permissions.
  • Have you checked AppArmor on Ubuntu or SELinux on RHEL? It is possible that they block because /opt is not a directory where www data can be served from.

Can you share your NginX configuration?

  • I’m on Opensuse 15.1 Leap.
  • I believe it has access. I added user Nginx to the tryton group and since tryton group should by right have access to /opt/sao, nginx should too. Hope I’m right about that.
  • I have dived into audit.log where AppArmor and SELinux log but I could not find anything there about either AppArmor and SELinux stopping Nginx access to the directory. Anywhere else I could look up?

Thank you.

You must set nginx to reverse proxy the requests to the trytond server. See