Mercurial hangs when pushing to tryton-env

I’m trying to push my latest change to tryton-env repository but it’s hanging when I run hg push. Here’s the output:

$ hg push ssh://
pushing to ssh://
pushing subrepo modules/account to ssh://
no changes found
pushing subrepo modules/account_asset to ssh://
no changes found
pushing subrepo modules/account_be to ssh://

Just to test, I tried pushing using http and the process reaches the latest repository (trytond) and fails due to authorization. So it seems the problem exists only with ssh connection.

Anybody else noticed the same problem? Any known way I could push tryton-env only? Given that trytond repository has already been pushed, maybe I could avoid pushing all repositories…

This is because there is a protection on the server that limit the rate of creation ssh connection to 5 per 2min.
You must configure hg and ssh to only make one connection, see

Worked well.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.