Import error: HarfBuzz not found

After install Tryton client 5.8 (tryton-64bit-last.exe) on windows 10 64 bit, it shown the error. Seem like missing Library.

Not only 64bit. I get the same message on 32bit.

Same for me on 4 different Win10 machines.

Please report on

A similar problem is discussed here:

It could be solved by some edits in the source files. Because I didn’t deploy Tryton in a Win64-only environment yet, have not solved that issue. But suggest using these recommendations.

Example of adding of the hook:

I filled Issue 9790: Missing HarfBuzz gir in tryton freezed - Tryton issue tracker
I posted a pre-build to test.

The prebuild seems to be working on my 2 machines. When I tried to connect it to my tryton instance I got an incompatible error. Thanks

Make sure you have also tryton server 5.8 on your server.

I had no problem with connection to

Is there a time frame for completion of the 5.8 Desktop version? Thanks

When you look at you see a -r1 version. Use that one.

We are stilling having issue with the Desktop client beyond just HarfBuzz.


We never had issue on the 5.6 client like this. But we moved to the client as per Ced so we could have adjustable fields so we could see all the columns . Now we are having issues this is impacting workflow. Thanks

This seems to a unrelated error. It seems a bug in the new version but may be not related to the desktop client.
It will be great if you can explain us how to reproduce in order to determine the origin of it and also share the full traceback (the content of your capture) to properly understand what happens.

Pokoli ty for the replay. share the full traceback (the content of your capture. I am not sure what this means or how to get the full traceback? That error popped up after install the new 5.8Rc1 desktop client and trying to connect to our server. how can I provide the information you asked thanks

THis means the content that is shown in the text area above the Report Bug link. This is an explanation of the error and allows developers to understand what is hapenning.

I have determined the error is coming from a custom module that our Dev has created he is looking into the root cause thank you for the help!