Image is not visible in Tryton Desktop Client

We first encountered this problem in Tryton Desktop Client 5.x. Image widget was visible on the form, but the image itself was not. Then we managed to solve this by replacing the library libgdk_pixbuf-2.0-0.dll with an older version. But after such a replacement in Tryton Desktop Client 6.x we have got an error message.

Windows 32bit, after entering the password:

  File "C:\msys64\home\ced\tryton-6.2-32/tryton/gui/", line 258, in do_command_line
  File "C:\msys64\home\ced\tryton-6.2-32/tryton/gui/", line 255, in do_activate
  File "C:\msys64\home\ced\tryton-6.2-32/tryton/gui/", line 532, in get_preferences
  File "C:\msys64\home\ced\tryton-6.2-32/tryton/gui/", line 739, in sig_win_menu
  File "C:\msys64\home\ced\tryton-6.2-32/tryton/gui/window/view_form/screen/", line 140, in __init__
  File "C:\msys64\home\ced\tryton-6.2-32/tryton/gui/window/view_form/screen/", line 538, in switch_view
  File "C:\msys64\home\ced\tryton-6.2-32/tryton/gui/window/view_form/screen/", line 565, in load_view_to_load
  File "C:\msys64\home\ced\tryton-6.2-32/tryton/gui/window/view_form/screen/", line 581, in add_view_id
  File "C:\msys64\home\ced\tryton-6.2-32/tryton/gui/window/view_form/screen/", line 608, in add_view
  File "C:\msys64\home\ced\tryton-6.2-32/tryton/gui/window/view_form/view/", line 65, in parse
  File "C:\msys64\home\ced\tryton-6.2-32/tryton/gui/window/view_form/view/", line 16, in <module>
  File "C:\msys64\home\ced\tryton-6.2-32/tryton/gui/window/view_form/view/form_gtk/", line 9, in <module>

Error: g-invoke-error-quark: Could not locate ev_init: 'libevdocument3-4.dll': The specified procedure was not found. (1)

Windows 64bit, before entering the password:

How can we solve this issue?

Maybe the gdk-pixbuf.loaders file is no more up to date. You should fill an issue.

I guess this is expected if you replace existing libraries.

Do you mean the file “Program Files\Tryton-64bit-6.2\etc\gtk-3.0\gdk-pixbuf.loaders” ?
Its date is 01-11-2021, its size is 3421.

I mean it is maybe no more up to date with the latest version of pixbuf library.

Sure. But this trick works in Tryton Desktop Client 5. :slightly_smiling_face:

Do we need to update the gdk-pixbuf.loaders file or pixbuf library? How exactly?

We have found that the png and gif formats display well in image widgets, but the jpg and tiff formats do not. Previously we exclusively used the jpg format.
What’s wrong with the jpg and tiff formats?

I tried the windows client 6.2 64bit and 5.0 32bit and they both can display jpg picture.

This is strange. I have just tried loading an avatar in the tab Administration / Users. The jpg picture is not displayed. The png picture is displayed, but disappears after Next Record and Previous Record, as it is being converted to jpg format .
What is wrong with our Tryton Client or Windows?

I just tried it out of curiosity and the same happens here. I’ve just started Windows 10, downloaded the most recent version of 6.2 64bit client and installed it. Did go to and logged in as admin. Then opened the user demo_nl and only saw the avatar as a rectangular gray box with two buttons (save and remove). Saving the avatar as jpeg to disk and opening it with another program revealed the contents of it.

So I removed the avatar and added another jpeg file as avatar. It didn’t work. The avatar box stays grey. When you login with sao, the jpeg avatar is shown correctly.

Indeed I retried on the Windows build machine. The jpg are displayed when the exe is launch from the MSYS2 environment. But they are not when launch from the Windows environment.
So for me it looks like we are missing a dll dependency (which is found in the MSYS2) but looking at ldd output I can not find which one. It is probably a dynamic one.

I don’t have MSYS2 on my system, but can it be something with the loader DLL files? When you look into C:\Program Files\<tryton>\lib\gdk-pixbuf-2.0\2.10.0\loaders you will see several DLL files. Maybe those DLL files are also in the MSYS2 environment but are different versions?

They come from MSYS2 as it is the system used to build the bundle.

Happy New Year!
Can we hope for a solution to this problem?