How to setting up timezone


I’ve trying to change the timezone used by tryton server, but until now I don’t know how to config.

The linux server and postgres database shows a correct time but trytond still logging as UTC timezone and all the new data in the DB’s tables, we need setup it to UTC-3.

How can I do it?

thanks in advance.

You can not change that. trytond must always run in UTC. It is the client that is responsible to display date/time in the user timezone.

Hello, I am new to the post. 2 years ago I use tryton for my little lab with the gnuhealth module. It really is wonderful and very functional.
I have the same problem for a long time without solving.
The company is configured in the correct time zone (america / santiago) which is UTC -3. However, all reports appear with UTC 0.
I have also checked that the data is saved to the postgres database at UTC 0.
I run tryton 5.0 on opensuse leap 15.2.
Thank you very much

No standard Tryton report display any datetime so it must be custom reports.
As they are executed on server-side they must take care of formatting the datetime with the proper timezone (see Report.format_datetime).

They are not the standard tryton reports. Reports are the gnuhealth defaults. But, we have already tried many ways with no success, finally we solve it in an unsuitable way by adding “datetime.timedelta (hours = 3)” in the report.

The method Report.format_datetime take a timezone as parameter. So usually you pass the company timezone to.

You may open the sales, invoice, purchase module… looking for the report. There are date , you may have a look

There is no timezone on date only datetime can have a timezone. So as I said we no report in standard which display datetime.