How to Complete Remove a Module from trytond\modules folder

I was trying to add a module “Library” before using the tutorial: 5.0 step1 · coopengo/tryton-training Wiki · GitHub

But now I want to delete it and every time I delete the folder manually by going to the folder and run the tryond-admin command afterwards it says:

FileNotFoundError: No such file or directory: 'D:\\#PROJECTS\\#GitRepos\\Tryton\\tryton\\trytond\\trytond\\modules\\library\\tryton.cfg'

Is there any proper way to completely dispose the module. For instance, even if I delete the content inside the folder as long as I am keeping .cfg file it still allows me to use trytond-admin command to install other modules. However, if I delete the folder from trytond/modules it give me this error.

You should deactivate first from the database and then remove it from the filesystem.

That should fix the error.

1 Like

I have deactivated the module (not sure how can I do that in the database), but it is still giving me this error.

This module was also depended on two other modules:

  1. ir
  2. res

I have removed the “library” entry from ir_module (in database) not sure about the other one.

After messing with the code a little I found out that this has this entry point. Back there it was something like library = trytond.modules.library

but now I changed it to trytond_library = trytond.modules.trytond_library and for some reason it is giving me the same error message but this time with “trytond_trytond” missing.

Is there’s anyway to reverse the damange I’ve done?

In my opinion, you need to add symbolic links of the library folder from trytond/modules/ to the actual folder containing the module code. For example you have the trainning-trytond_library located in /home/someone/work/trainning-trytond_library, hence you should have a symbolic link named trytond_library inside trytond/modules pointing to /home/someone/work/trainning-trytond_library

Hence if you remove the actual folder, you may also need to make sure the symbolic link is removed. This is just my guess to your problem. Can you check if you see any broken links in the trytond/modules folder?

1 Like

Yeah! I just fixed it. Instead of using a different symbolic-link/directory “training-trytond_library” to simply “library” and seems like it is working for now.

I only reason why I wanted to do this in the first place is because I’ve got a directory for my “local_modules” which is seperated from the “modules” (for better organization)

This topic was automatically closed 12 hours after the last reply. New replies are no longer allowed.