Get account_export running

Hello everybody,
i try to get the new module “account_export” running on version 7.0.latest. (i downgraded the version from 7.1. since i have the same error as in Clone repository).
I run into the following error whe installing account_export

File "/Users/jakobfischer/virtpy/trytond/lib/python3.12/site-packages/trytond/model/fields/", line 126, in sql_format
    value = int(value)
ValueError: invalid literal for int() with base 10: 'account.move.export'

The above exception was the direct cause of the following exception:

Traceback (most recent call last):
  File "/Users/jakobfischer/virtpy/trytond/bin/trytond-admin", line 31, in <module>
  File "/Users/jakobfischer/virtpy/trytond/lib/python3.12/site-packages/trytond/", line 57, in run
    pool.init(update=options.update, lang=list(lang),
  File "/Users/jakobfischer/virtpy/trytond/lib/python3.12/site-packages/trytond/", line 167, in init
    restart = not load_modules(
  File "/Users/jakobfischer/virtpy/trytond/lib/python3.12/site-packages/trytond/modules/", line 389, in load_modules
  File "/Users/jakobfischer/virtpy/trytond/lib/python3.12/site-packages/trytond/modules/", line 357, in _load_modules
    load_module_graph(graph, pool, update, lang)
  File "/Users/jakobfischer/virtpy/trytond/lib/python3.12/site-packages/trytond/modules/", line 208, in load_module_graph
  File "/Users/jakobfischer/virtpy/trytond/lib/python3.12/site-packages/trytond/", line 466, in parse_xmlstream
    raise ParsingError("in %s" % self.current_state()) from e
trytond.convert.ParsingError: in record 'account_export.rule_group_account_move_export_companies'

As far as I understand, the model account.move.export is not registered, but looks fine to me, the class ist registerd.

Question: has this error something to do with versioning so I waste my time? Otherwise any hint available?

Yes the XML format has changed with Improve technical views (#13051) · Issues · Tryton / Tryton · GitLab

This topic was automatically closed 12 hours after the last reply. New replies are no longer allowed.