Failures when upgrading to Tryton 6.8 on Gentoo

Hello everyone again,

My apologies in advance for the inconvenience caused.

After solving the verification problems, a new problem has arisen, and it is a detail in the working directory of each new package in tryton 6.8 although they are not all, I tried them one by one and I got a list of 188 packages on my system with the same error.

The package list fail: fail package list

Here I show the currency as an example:
Emerging (2 of 186) app-tryton/currency-6.8.0::tryton
Unpacking source…
Source unpacked in /var/tmp/portage/app-tryton/currency-6.8.0/work
ERROR: app-tryton/currency-6.8.0::tryton failed (prepare phase):
The source directory ‘/var/tmp/portage/app-tryton/currency-6.8.0/work/currency-6.8.0’ doesn’t exist

  • Call stack:
  •, line  780:  Called __ebuild_main 'prepare'
  •, line 1072: Called __dyn_prepare
  •, line 400: Called die
  • The specific snippet of code:
  •  	die "The source directory '${S}' doesn't exist"
  • If you need support, post the output of emerge --info '=app-tryton/currency-6.8.0::tryton',
  • the complete build log and the output of emerge -pqv '=app-tryton/currency-6.8.0::tryton'.
  • The complete build log is located at ‘/var/tmp/portage/app-tryton/currency-6.8.0/temp/build.log’.
  • The ebuild environment file is located at ‘/var/tmp/portage/app-tryton/currency-6.8.0/temp/environment’.
  • Working directory: ‘/var/tmp/portage/app-tryton/currency-6.8.0/empty’
  • S: ‘/var/tmp/portage/app-tryton/currency-6.8.0/work/currency-6.8.0’

Failed to emerge app-tryton/currency-6.8.0, Log file: /var/tmp/portage/app-tryton/currency-6.8.0/temp/build.log’

From what I can intuit after reading some posts with similar packages in the gentoo forum, the possible cause is the lack of updating the working path in each package, coupled with the previous error, it could be that the tryton/gentoo repository It is not fully updated or there is a synchronization problem.

I would be grateful if you could help me with your experiences and thus try to solve in some way

Thanks in advance

For me your cloned repository is corrupted.

My apologies for the inststenica and disagree with that statement dear,

I have verified that the basic installation works, but the rest of the modules, including the one for countries and currencies, continue to fail on 3 different computers, with different and independent clients, that rules out that the cloning of the repo is unsuccessful, it cannot be a coincidence They all fail for the same reason.

I found that some manifest were wrong (pkgdev does not support well hg) but I fixed it few days ago. I updated 2 different machines without problem.

Once again dear, I have made clean installations from scratch and trayton trytond and sao are installed perfectly, but when I get to currency or countries, the same error that you cannot find the source directory continues to appear.
Both in physical and virtual machines the result continues to be the same.

The source directory ‘/var/tmp/portage/app-tryton/currency-6.8.0/work/currency-6.8.0’ doesn’t exist

Something in the ebuild configuration maybe, it’s as if the routing went to the previous version maybe to compile the modules and that’s why it doesn’t find the sources.

doing new tests I have verified that the directory is created, but the sources are not inside.

build /var/db/repos/tryton/app-tryton/currency/currency-6.8.0.ebuild unpack
" * checking ebuild checksums :wink: … [ ok ]
" * checking auxfile checksums :wink: … [ ok ]
" * checking miscfile checksums :wink: … [ ok ]
" * Please clean PYTHON_COMPAT of obsolete implementations:
" * python3_8
" >>> Unpacking source…
" >>> Source unpacked in /var/tmp/portage/app-tryton/currency-6.8.0/work
" ls /var/tmp/portage/app-tryton/currency-6.8.0/work
(No sources is empty)

Some ebuilds were missing the new pypi eclass, it should be fixed with

Thank you for your valuable time dear friend Ced, it worked with all except dev-python/pysaml2 that gives a different error but I still think the ebuild needs to be updated

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) dev-python/pysaml2-7.4.1::tryton
 * pysaml2-7.4.1.tar.gz BLAKE2B SHA512 size ;-) ...                      [ ok ]
>>> Unpacking source...
>>> Unpacking pysaml2-7.4.1.tar.gz to /var/tmp/portage/dev-python/pysaml2-7.4.1/work
>>> Source unpacked in /var/tmp/portage/dev-python/pysaml2-7.4.1/work
>>> Preparing source in /var/tmp/portage/dev-python/pysaml2-7.4.1/work/pysaml2-7.4.1 ...
 * Build system packages:
 *   dev-python/gpep517            : 13
 *   dev-python/installer          : 0.7.0
 *   dev-python/setuptools         : 67.7.2
 *   dev-python/setuptools-scm     : 7.1.0
 *   dev-python/wheel              : 0.40.0
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/dev-python/pysaml2-7.4.1/work/pysaml2-7.4.1 ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/dev-python/pysaml2-7.4.1/work/pysaml2-7.4.1 ...
 * python3_10: running distutils-r1_run_phase distutils-r1_python_compile
 * DISTUTILS_USE_PEP517 does not match pyproject.toml!
 *     have: DISTUTILS_USE_PEP517=setuptools
 * expected: DISTUTILS_USE_PEP517=poetry
 * (backend: poetry.core.masonry.api)
 * ERROR: dev-python/pysaml2-7.4.1::tryton failed (compile phase):
 *   DISTUTILS_USE_PEP517 value incorrect
 * Call stack:
 *, line  136:  Called src_compile
 *   environment, line 3411:  Called distutils-r1_src_compile
 *   environment, line 1537:  Called _distutils-r1_run_foreach_impl 'distutils-r1_python_compile'
 *   environment, line  706:  Called python_foreach_impl 'distutils-r1_run_phase' 'distutils-r1_python_compile'
 *   environment, line 3116:  Called multibuild_foreach_variant '_python_multibuild_wrapper' 'distutils-r1_run_phase' 'distutils-r1_python_compile'
 *   environment, line 2613:  Called _multibuild_run '_python_multibuild_wrapper' 'distutils-r1_run_phase' 'distutils-r1_python_compile'
 *   environment, line 2611:  Called _python_multibuild_wrapper 'distutils-r1_run_phase' 'distutils-r1_python_compile'
 *   environment, line 1027:  Called distutils-r1_run_phase 'distutils-r1_python_compile'
 *   environment, line 1519:  Called distutils-r1_python_compile
 *   environment, line 1341:  Called distutils_pep517_install '/var/tmp/portage/dev-python/pysaml2-7.4.1/work/pysaml2-7.4.1-python3_10/install'
 *   environment, line 1863:  Called _distutils-r1_get_backend
 *   environment, line  516:  Called die
 * The specific snippet of code:
 *               die "DISTUTILS_USE_PEP517 value incorrect";
 * If you need support, post the output of `emerge --info '=dev-python/pysaml2-7.4.1::tryton'`,
 * the complete build log and the output of `emerge -pqv '=dev-python/pysaml2-7.4.1::tryton'`.
 * The complete build log is located at '/var/tmp/portage/dev-python/pysaml2-7.4.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-python/pysaml2-7.4.1/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-python/pysaml2-7.4.1/work/pysaml2-7.4.1'
 * S: '/var/tmp/portage/dev-python/pysaml2-7.4.1/work/pysaml2-7.4.1'

>>> Failed to emerge dev-python/pysaml2-7.4.1, Log file:

>>>  '/var/tmp/portage/dev-python/pysaml2-7.4.1/temp/build.log'

Looks like the Python team have again broken everybody works with only their own usage in mind.

1 Like

Infinitely grateful, I was able to update everything without complaints, the new improvements are really impressive