Exception: “tryton” is not a Tryton database

Ubuntu 20.04
Tryton 5.0.17 (Installed from Ubuntu repositoryes)

On system user ‘tryton’ is created.
On postgre server role ‘tryton’ is created with database ‘tryton’ and pwd ‘trypw’.

/etc/tryton/trytond.conf

path = /var/lib/tryton
uri = postgresql://tryton:trypw@localhost:5432/

/etc/postgresql/13/main/pg_hba.conf

local set to md5

sudo -u tryton trytond-admin -c /etc/tryton/trytond.conf -d tryton -–all
Traceback (most recent call last):
  File "/usr/bin/trytond-admin", line 21, in <module>
    admin.run(options)
  File "/usr/lib/python3/dist-packages/trytond/admin.py", line 34, in run
    raise Exception('"%s" is not a Tryton database.' % db_name)
Exception: "tryton" is not a Tryton database.

Same result with SQLite (empty database file created /var/lib/tryton/tryton.sqlite)

It looks like the --all option is not correctly passed to trytond-admin.
The exception line 34 is raised when a database is passed as argument (but without any update) and that the database has not been initialized.

Thank you, Cédric
Is there any solution? I have tried it on different system with same result.

Is there any recent, step by step and, most importantly, complete guide to install, configure and run Tryton server and configure and run client on Linux system?
This would have helped the small associations without a qualified IT personal to try this software.
Thanks again for your time

Are you copying and pasting this line?

The two dashes before the all look like they are different characters. The first dash looks like a normal dash, but the second dash looks longer like a n-dash.

They both must be https://en.wikipedia.org/wiki/Hyphen-minus characters.

Thank you David
You are absolutely wright - this was an error on characters in ’ -–all’. I have copied it from internet and did not notice the mistake.
Will be a lesson for me.
Thank you again

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.