Error when installing the "account_es" module

It gives a timeout error when the module is being installed.

Can anything be done for your solution?

Probably the timeout is produced due to a proxy in front of tryton.

YOu should increase the timeout of your proxy and the process will end correctly.

Sergi, I don’t have any proxy between triton and the internet. Could it be something else?

gunicorn has also a timeout.

Is there something quick to extend that Gunicorn time?

There is the timeout settting.

To be able to do it in tryton’s Docker?

Set GUNICORN_CMD_ARGS=--timeout 600

1 Like

I have little knowledge about Dockers, exactly where should this instruction be placed for it to work?

See How do I pass environment variables to Docker containers? - Stack Overflow

Placing this seems to work but when I install the “account_es” module it still fails.

When I enter the following command I get this on the screen:

  • Command: docker run -e GUNICORN_CMD_ARGS=“–timeout 600” tryton/tryton
  • Screen:

It may need a higher timeout.

Anyway, I’ve been watching while I was trying to install the module and it takes about 25 seconds to get the error.

Could it be that before installing that module you have to install another one first?

This sounds like the default 30s of gunicorn so I guess the parameter is not correctly passed.

should be GUNICORN_CMD_ARGS="--timeout=600"

With the new parameter it also fails me at exactly 30 seconds.

So it is not applied correctly and you are not using the instance for which you set the environment.

This is what appears in the log in case it is of any use:

In this instruction that we use to create tryton, can the timeout thing be implemented?:

sudo docker run \
    --name tryton \
    --env DB_HOSTNAME=tryton-postgres \
    --mount source=tryton-data,target=/var/lib/trytond/db \
    --network tryton \
    --publish 8000:8000 \
    --detach \


$ docker run --name tryton --env DB_HOSTNAME=tryton-postgres --env DB_PASSWORD=“${POSTGRES_PASSWORD}” --env GUNICORN_CMD_ARGS="--timeout=600" --mount source=tryton-data,target=/var/lib/trytond/db --network tryton --publish 8000:8000 --detach tryton/tryton

But you must stop previous container running with:

$ docker kill tryton

PS: do not use screenshot to display text, copy/paste it using preformatted text

With this instruction it opens in the browser with Tryton, but it does not show the Database to select it

Inside the Tryton Docker (accessing as root) and in the file: “/etc/”
At the end I put: timeout=‘3600’

With the Firefox browser and it worked the first time.
I have already been able to install the “account_es” module

Note: I recommend that once the “account_es” module is installed, delete the line that we have added in case it fails somewhere in the program to show it to us in a timely manner.