Error Tryton Sao " Calling method resources on is not allowed"

Hi all I am new to Tryton, just managed to install tryton sao , and i am able to call it from a web browser, I am even able to log into the database but, I am consistently getting a message " Calling method resources on is not allowed" however I have gone through previous discussions and installed 4.6 branch of sao.

My path to the sao in trytond.conf is correcctly set.

Can anybody help me in getting rid of this error.

Series 4.6 is no more supported since November 2019.
You should first try on supported series like 5.0 or 5.4.

Yes i did try with 5.4 and 5.0 , now the web display is completely gone , and i have attached the screen shot

It seems that you cloned the sources but you did not build it. Did you run grunt?

@pokoli , Thankyou for your suggestion, I followed the readme file and now it seems to be working, with a glitch. Whenever I try to click any menu options i get the following error, Any pointers to resolve this would be appreciated.

Which version are you using?, I can see you have on background health modules, gnuhealrh works with 5.0.15 server, you you need same sao version

Hi there, thank you for assisting.
I am using the latest version of sao , do you think i need to go back to version 5.0
because i tried with 5.0 previously and was getting the same error.

Yes, check your trytond --version and then get same version with all numbers for sao.

And repeat the installation , also don’t use root for the installation .

I’ve seen on your module list that you use the 4.6 series (which is unsuported). If you plan to use this version you should use the 4.6 sao series also. Server, clients and modules should alwasy be from the same series (first two digits of the version number).

As the 4.6 series is unsuported I will recomend updating your whole instalation to a more recent versions. Have a look at the maintenance section of our release process.

Thanks to all for help, i reverted back to 4.6 SAO, but still the problem persisted, later after updating the npm, got rid of the error. Since then have not faced any issues.
Once again thank you to all for help.