Browser error with Trytond.bus

I’ve configured Nginx as proxy for tryton to use notifications from trytond.bus, everything seems to be ok, I can now connect to Tryton via SSL, and the notifications are correctly displayed.
But im constantly getting this error in firefox:

All I found about this is giving more Time-out time to Nginx, but doing this ends up on the same result but “502 Bad Gateway” instead, in Tryton configuration file I’ve only added allow_subscribe option to bus section, maybe theres something else missing? and I don’t know if this really matters, as the proxy is working as expected.

Do you run the bus with the main server? If yes, it is not ideal but you must configure your WSGI server to have a timeout at least equal to the [bus] long_polling_timeout.

Ideally you should run the bus as separate process with the --coroutine option so it can handle long-polling requests without consuming too much resources. Or you must configure your WSGI server to use a “coroutine” like approach for the bus requests.

This topic was automatically closed 12 hours after the last reply. New replies are no longer allowed.