# Missing menu text after upgrade

**URL:** https://discuss.tryton.org/t/missing-menu-text-after-upgrade/8177
**Category:** System Administrator
**Created:** [January 9, 2025, 10:48am UTC](https://discuss.tryton.org/t/missing-menu-text-after-upgrade/8177 "2025-01-09T10:48:21Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![hbrandes](https://discuss-cdn.tryton.org/letter_avatar_proxy/v4/letter/h/f1d935/32.png) [@hbrandes](https://discuss.tryton.org/u/hbrandes)
#### Post date: [January 9, 2025, 10:48am UTC](https://discuss.tryton.org/t/missing-menu-text-after-upgrade/8177/1 "2025-01-09T10:48:22Z")

</div>

Good Morning,

we did an upgrade of the database from 6.8 to 7.4 - regarding all steps from the migration page and fix all errors during the upgrade process.

Now, when connecting to tryton, the menu structure is not shown correctly:

 ![image](https://discuss-cdn.tryton.org/uploads/default/original/2X/b/b4bb7d014b73e8221e3b3aee4bb851a89c21816f.png)

Sadly, we cannot go to Administration → Model → Data and synchronize everything, because the menu is not opened anymore. Within the log, we cannot recognize any related error for that situation. In the old 6.8 installation the user is member of the “Administration” group.

We tried to clear some caching tables but without sucess.

Thank you and best regards,  
Hendrik

---

<div class="post-metadata">

### Author: ![ced](https://discuss-cdn.tryton.org/user_avatar/discuss.tryton.org/ced/32/1237_2.png) [@ced](https://discuss.tryton.org/u/ced)
#### Post date: [January 9, 2025, 11:12am UTC](https://discuss.tryton.org/t/missing-menu-text-after-upgrade/8177/2 "2025-01-09T11:12:41Z")

</div>

This is typical of a read error on an `ir.menu` record usually it is the linked action that does not exist or some user access restriction.  
You should look at the request from the client to detect the one that is failing and see the error message of the server.

---

<div class="post-metadata">

### Author: ![lars\_wuerfel](https://discuss-cdn.tryton.org/user_avatar/discuss.tryton.org/lars_wuerfel/32/2794_2.png) [@lars\_wuerfel](https://discuss.tryton.org/u/lars_wuerfel)
#### Post date: [January 9, 2025, 12:04pm UTC](https://discuss.tryton.org/t/missing-menu-text-after-upgrade/8177/3 "2025-01-09T12:04:52Z")

</div>

I had this situation multiple times since I switched from Apache2/uWSGI to nginx/gunicorn. I think it happens when I install a module that creates a new menu entry and/or adds new fields to an existing model.  
After restarting the server, operation is normal and the error is gone.

This does not happen when I start trytond directly (trytond -c …) and it did not happen when I used Apache2/uWSGI, so I think it is a problem with my gunicorn configuration, but I did not yet investigate.

Maybe a server restart helps.

---

<div class="post-metadata">

### Author: ![hbrandes](https://discuss-cdn.tryton.org/letter_avatar_proxy/v4/letter/h/f1d935/32.png) [@hbrandes](https://discuss.tryton.org/u/hbrandes)
#### Post date: [January 10, 2025, 8:25am UTC](https://discuss.tryton.org/t/missing-menu-text-after-upgrade/8177/4 "2025-01-10T08:25:05Z")

</div>

Thank you for the hint.

I finally increased the log level and then inspect the tables ir\_ui\_menu and ir\_action\_act\_window and found out, that one of the migration sql scripts removed the missing entry.

---

<div class="post-metadata">

### Author: ![system](https://discuss-cdn.tryton.org/uploads/default/original/1X/c6f8ec0a40525cdcd50058c734283450a4b3d38b.png) [@system](https://discuss.tryton.org/u/system)
#### Post date: [January 11, 2025, 8:25am UTC](https://discuss.tryton.org/t/missing-menu-text-after-upgrade/8177/5 "2025-01-11T08:25:14Z")

</div>

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.
